wireling Pi HAT config error

Leeyt4541

  • Newbie
  • *
    • Posts: 3
    • View Profile
Hi all,

I'm using the Raspberry Pi to test the accelerometer and Pi HAT and I met a problem while following the tutorial provided by Tinycircuits. After installing all the packages mentioned in the tutorial, I run an example code and I got an error that said '"Adafruit-PlatformDetect version 3.40.3 was unable to identify the board and/or microcontroller running the Linux platform. Please be sure you have the latest packages running:'pip3 install --upgrade adafruit-blinka adafruit-platformdetect'". I run the command and it said the requirement was already satisfied. Could anyone please help me fix this error so that I can keep using the HAT and next the accelerometer? Thanks.

Best,
Yuntao


Jason

  • Administrator
  • Hero Member
  • *****
    • Posts: 102
  • TinyCircuits Employee
    • View Profile
I was able to get that example working fine on my Raspberry Pi 3 Model B V1.2.

Can you provide the following?
  • Board name
  • Board version
  • OS name
  • OS version


Leeyt4541

  • Newbie
  • *
    • Posts: 3
    • View Profile
I was able to get that example working fine on my Raspberry Pi 3 Model B V1.2.

Can you provide the following?
  • Board name
  • Board version
  • OS name
  • OS version

I'm using the AST1001 accelerometer and the wireling Pi HAT. The Raspberry Pi I'm using is the same as yours and I installed the newest version of the OS. I just use a new SD card and downloaded the newest OS in it and run this OS on Raspberry Pi 3 v1.2 board.


Jason

  • Administrator
  • Hero Member
  • *****
    • Posts: 102
  • TinyCircuits Employee
    • View Profile
I'm using the AST1001 accelerometer and the wireling Pi HAT. The Raspberry Pi I'm using is the same as yours and I installed the newest version of the OS. I just use a new SD card and downloaded the newest OS in it and run this OS on Raspberry Pi 3 v1.2 board.

Could you try following the steps in this link? https://stackoverflow.com/a/74147334

What is the value of 'revision' in the output of the first command?
Code: [Select]
cat /proc/cpuinfo
For me it is a22082


Leeyt4541

  • Newbie
  • *
    • Posts: 3
    • View Profile
I'm using the AST1001 accelerometer and the wireling Pi HAT. The Raspberry Pi I'm using is the same as yours and I installed the newest version of the OS. I just use a new SD card and downloaded the newest OS in it and run this OS on Raspberry Pi 3 v1.2 board.

Could you try following the steps in this link? https://stackoverflow.com/a/74147334

What is the value of 'revision' in the output of the first command?
Code: [Select]
cat /proc/cpuinfo
For me it is a22082

Hey,

Thanks for your reply but it seems I can use the accelerometer without connecting the Pi HAT. But I have a further question: what is the unit of acceleration in three axes and how can I transfer this value to the actual acceleration in m/s^2? I tried to figure it out but failed. I think transferring the raw data to the actual acceleration needs a scaling factor but I don't know this specific factor for BMA250.

Thanks!


 

SMF spam blocked by CleanTalk