TinySaber upload not working

Roger Lee

  • Newbie
  • *
    • Posts: 2
    • View Profile
I got a TinySaber at the Detroit Maker Faire last weekend.
(my wife also got a Tiny Piano )

using arduino IDE 1.8.5
board: "TineSaber Rev2"
programmer: "arduino as ISP"

trying to upload the sample TinySaber code.
the sample code does verify.

this is the output from upload attempt.
Code: [Select]
Running Digispark Uploader...
Plug in device now... (will timeout in 60 seconds)
Warning: device with unknown new version of Micronucleus detected.
This tool doesn't know how to upload to this new device. Updates may be available.
Device reports version as: 2.3

What am I doing wrong here. 
Thanks for any help.



  • Administrator
  • Hero Member
  • *****
    • Posts: 437
    • View Profile
Hello Roger,

Do you know what version of Zadig you downloaded? This may have something to do with the error you received.

Please let me know if a version fix helps or if it's still not uploading!


Roger Lee

  • Newbie
  • *
    • Posts: 2
    • View Profile
Thanks for reply Réna,

I did not download version of Zadig ( USB driver )
That appeared to be for Windows machines.

Seems I have left out an important detail, my operating system. Sorry.
running Ubuntu 16.04
( Also tried it on Linux Mint 17 , similar results. j
I do not have easy access to Windows , but probably can find one if I have to.



  • Newbie
  • *
    • Posts: 1
    • View Profile
I was able to get past this error by downloading a more recent copy of micronucleus from here
and replacing the micronucleus binary that the ArduinoIDE was using with the new micronucleus binary.
Mine was in ~/home/johnpaul/.arduino15/packages/TinyCircuits/tools/micronucleus/2.0a4/
It is 2.0a4 because that's what the tinycircuits JSON from the instructions requests.

After this, when I uploaded the sample code from the TinyCircuits site, the text display and saber modes broke.
Rainbow mode and flashlight mode still worked.

I narrowed the problem to the board not getting good accelerometer data. It seemed to think it was constantly getting a double tap and also wasn't reacting to x motion changes for text.

I physically unplugged the battery, then pushed the reset button a few times. When I plugged the battery back in, it properly works with the accelerometer again and all example modes work.
« Last Edit: July 01, 2023, 10:02:53 PM by batinthestacks »


SMF spam blocked by CleanTalk