TinySaber upload not working

Roger Lee

  • Newbie
  • *
    • Posts: 2
    • View Profile
I got a TinySaber at the Detroit Maker Faire last weekend.
(my wife also got a Tiny Piano )

using arduino IDE 1.8.5
board: "TineSaber Rev2"
programmer: "arduino as ISP"

trying to upload the sample TinySaber code.
the sample code does verify.

this is the output from upload attempt.
Code: [Select]
Running Digispark Uploader...
Plug in device now... (will timeout in 60 seconds)
Warning: device with unknown new version of Micronucleus detected.
This tool doesn't know how to upload to this new device. Updates may be available.
Device reports version as: 2.3

What am I doing wrong here. 
Thanks for any help.



  • Administrator
  • Hero Member
  • *****
    • Posts: 437
    • View Profile
Hello Roger,

Do you know what version of Zadig you downloaded? This may have something to do with the error you received.

Please let me know if a version fix helps or if it's still not uploading!


Roger Lee

  • Newbie
  • *
    • Posts: 2
    • View Profile
Thanks for reply Réna,

I did not download version of Zadig ( USB driver )
That appeared to be for Windows machines.

Seems I have left out an important detail, my operating system. Sorry.
running Ubuntu 16.04
( Also tried it on Linux Mint 17 , similar results. j
I do not have easy access to Windows , but probably can find one if I have to.



SMF spam blocked by CleanTalk