Tinyscreen video game kit dead

Scruit · 3 · 4220


  • Newbie
  • *
    • Posts: 1
    • View Profile
Tinyduino video game kit.  I can get the amber light for charging when I plug into my laptop via usb, and I can see the green light flashing as the laptop tries to communicate via usb, but other than that the unit is dead.

I have the boards assembled as Screen>Joystick>USB>TinyDuino.

Screen shows nothing.  The on-off button has zero effect.

The instruction card came with simple instructions to plug the duino/usb/screen together and charge, but after 8 hours of charging I get nothing.  Also the URL on the card (http://tinycircuits.com/TinyScreen) forwards to https://tinycircuits.com/TinyScreen and results in "page not found".

I had an arduino leonardo so I'm not new to this.

I'm assuming the unit is DOA, unless I am doing something wrong, but as al I have done it plug the 4 components together and plug in the USB for 8 hours, I'm not sure what I could have done wrong?

Ben Rose

  • Administrator
  • Hero Member
  • *****
    • Posts: 392
    • View Profile
Hi- sorry about it appearing DOA, it's possible the boards were sent out without the example being loaded. Have you tried programming them with our example code with the correct settings in the IDE? If you've already tried that, please contact info@tinycircuits.com


  • Newbie
  • *
    • Posts: 1
    • View Profile
I seem to have the same problem. I've charged up the game kit. The orange light turns on while charges and dissappeared over night. But when I turn it on, nothring happens.

I've tried debugging by only plugging in the TinuDuino and the screen. Still absolutely no sign of life when turning on (Screen is entirely black)

When I plug the module into my PC, leds start flashing green and it's detected correctly.
The CodeBender App seems happy in Chrome and I get a COM4 port on my PC.
However, when I try to upload a sketch using the "TINYDUINO VIDEO GAMES TUTORIAL", I get the error message "Could not connect to your device. Make sure that you have connected it properly, that you have selected the correct settings (device type and port) and try again. More Info". The more info link leads to a missing page.
I selected TinyDuino and COM4 in the plugin.
I've also tried removing all the shields except for the USB one while uploading. No luck

By the way; you should include the screw an spacer kit with the video game kit.


SMF spam blocked by CleanTalk