BT LE example does not even compile

BT LE example does not even compile
« on: February 06, 2014, 05:02:06 PM »
Tinyduino compiles and runs blink so at least we know our system works. However, the example for the bluetooth LE module on the website does not compile for me. I have board marked Rev2 and I got the sketch for Rev2. The complier complaints start with ... multiple definitions of \BGlib::checkError()  and just goes on from there.  Any ideas ?

Re: BT LE example does not even compile
« Reply #1 on: February 06, 2014, 06:13:02 PM »
Hi Heliboy,

It sounds like some of the BGLib files are not present in your sketch directory, if you scroll down to the bottom of the page at:  http://tiny-circuits.com/learn/using-the-bluetooth-low-energy-tinyshield/ you see a link to download a zip file with the sketch along the BGLib files.  Can you verify that you've downloaded all of that and are still having issues?



Re: BT LE example does not even compile
« Reply #2 on: March 13, 2014, 08:53:45 PM »
I have the same problem. I downloaded the file in the link but, I keep getting same error message.

getting the Bluetooth Low Energy TinyShield to communicate with Android
« Reply #3 on: March 26, 2014, 06:11:27 PM »


So far, my Android phone cannot see my bluetooth TinyDuino, despite uploading the sample bluetooth sketch,<https://github.com/jrowberg/bglib/tree/master/Arduino/Examples/BGLib_stub_slave> via usb to the TinyDuino, and trying out the MeetAndroid sketch from <http://www.amarino-toolkit.net/index.php/download.html>.

Can anybody with Android familiarity advise on some useful steps to get an Android phone talking with a TinyDuino?


Re: BT LE example does not even compile
« Reply #4 on: June 16, 2014, 09:17:18 PM »
You get this error if you imported the BGLIB library into Arduino and then try to run the sketch from the downloaded zip file. To run the sketch, do either of these two:

1. Don't import the BGLib library into arduino and just run the sketch from the unpacked Zip file


2. Manually copy the unpacked Zip file into your libraries folder.

Whatever you do, DO NOT import the library directly from the Zip. I got the same errors and fixed it that way.