.42" OLED usage with Arduino UNO?

steve_eo

  • Newbie
  • *
    • Posts: 1
    • View Profile
Hi there.
I have the 0.42" display and an UNO.
I have downloaded the examples and wired the display as:
J1.1 to GND on the Arduino board
J1.2 to 3.3 on the Arduino board
J1.3 to A5 on the Arduino board
J1.4 to A4 on the Arduino board
J1.5 to A0 on the Arduino board
BTW, to make these connections, I disconnected one end of the 5 pin Wireling cable and soldered on pins that fit correctly into the UNO sockets.
The result of running the example code from 0.42-Screen-Text-Example is a screen with a bunch of random white bits.
Perhaps I'm connecting something wrong?
Can anyone please comment if they see something I'm doing wrong.
Thank you!
-Steve



lennevia

  • Administrator
  • Hero Member
  • *****
    • Posts: 115
    • View Profile
Hey there Steve,

The random white bits mean that the screen is not correctly being initialized.

The Arduino UNO will supply 5V, when the 0.42" Wireling is meant to be used with 3.3V - so there is a possibility that the power difference could be causing issues.

There are a couple of solutions to output 3.3V from the Arduino UNO: https://www.quora.com/Is-there-any-way-to-have-an-Arduino-Uno-pin-output-3-3V-instead-of-5V-when-it-is-high-looking-for-a-non-PWM-solution

It is, however, possible that the 0.42" Screen could be damaged. If you have a Wireling Adapter Shield or other Wireling-specific hardware, I would advise you to test with this before moving forward so that you can make sure the screen is still functioning.

I hope that helps!

Thank you,

Laveréna
« Last Edit: May 05, 2020, 03:45:52 PM by lennevia »


 

SMF spam blocked by CleanTalk