[inprogress] What servo angles should be used for calibration for Tiny Arm?

AlanKilian

  • Full Member
  • ***
    • Posts: 16
    • View Profile
The RobotZero preprogrammed code does not calibrate all servos the same.
(It does not even calibrate all the servos)

In order to assemble the arm, the servos need to be calibrated.

What servo angle should be used for calibrating prior to assembling of the arm?

(I also used the RobotArmExample, but it also drives different servos to different angles so calibration is not possible using that.)


lennevia

  • Administrator
  • Hero Member
  • *****
    • Posts: 104
    • View Profile
Hello Alan,

It looks like there was some sort of bug in the servo code. It was fixed up by Ben, and will be corrected on the website. For now, it is corrected in the GitHub repo, and you can download it:

Premium Robot Kit Corrected Code


AlanKilian

  • Full Member
  • ***
    • Posts: 16
    • View Profile
I still don't think things are correct yet.

In the assembly instructions, I read
Quote
STEP 6: NOTE: Calibrate all servos before continuing to do this plug all servos into the RobotZero processor with a charged battery (to charge: plug the battery into the RobotZero, and plug the RobotZero into a power source using a Micro USB cable). When plugged in, the servos will be centered. Be careful not to move the output shafts once calibrated.

But when I look at the latest code I see this in setup()
Code: [Select]
  servo.setServo(1, 1500);
  servo.setServo(2, 1500);
  servo.setServo(3, 1500);
  servo.setServo(4, 1500);

Which WILL center the servos, however, 1 second later, the servos are moved to different positions:
Code: [Select]
  closeClaw(200);
  servo.setServo(frontBackServo, 2200);
  servo.setServo(upDownServo, scanningHeightServoPosition);

Which sets the claw to closed (I think this is correct because the claw is assembled closed in the assembly instructions)

However, I'm not sure if the frontBackServo and upDownServo assembly matches these servo arm positions.

I'll take the robot apart, run this code and then complete the assembly and let you know.


AlanKilian

  • Full Member
  • ***
    • Posts: 16
    • View Profile
Latest update: With no wirelings connected, indeed all servos are set to mid.

However, the claw is assembles closed and therefore when the final code is run with wirelings connected, the claw attempts to close from mid and jams.

The claw servo needs to be initialized to closed buy plugging it in to a SPECIFIC servo connection on the RobotZero board and then the users need to keep track of that servo and make SURE it is used to assemble the claw.

This might be a little difficult to explain and properly execute.


 

SMF spam blocked by CleanTalk