Issue with Micro SD card reading

spetznatz1@gmail.com

  • Newbie
  • *
    • Posts: 2
    • View Profile
Hello, I wanted to ask how I can fix a recent error that has started on my TinyArcade. I was an early backer for the Tiny Arcade, and since having it, it has worked without issue since. However lately, I get a problem where when I turn on the TinyArcade, it tells me no SD Card was found, yet it still brings up the “Tiny Shooter” game but that’s it. I did buy the pre-loaded card from your company and I checked and all the game files and the demo videos are on it, but the arcade still doesn’t see any of them. It is strange because even though it states “no SD card found” it still brings up the game I mentioned earlier. I tried to reconfigure the SD card and update it with all the new games, but it still doesn’t see any thing but the Tiny Shooter.
 I thought perhaps I needed to just reprogram the board via the Arduino IDE, but to do that I need the files for the TinyScreen. On your website you state that we need to copy the following URL and add it to the Board Manager so I could update the Board but this link doesn’t work in Arduino IDE. Is there a new link?
I also tried to email the company, but the email address is dead as well.


mjculross

  • Full Member
  • ***
    • Posts: 22
    • View Profile
If I remember correctly, the TinyArcade will allow you to play the last game loaded, even without the SD card installed (you should be able to verify this by powering down, completely removing the card, & powering back up).  As for reprogramming the board (you should not have to, but doing so can be instructional), make sure you follow all of the steps given at https://learn.tinycircuits.com/Help/Tiny-Arcade-DIY-Kit_Menu-Update/, particularly the setup steps at https://learn.tinycircuits.com/Processors/TinyScreen+_Setup_Tutorial/.  Once you've included the URL in the "Additional Boards Manager URLs" box in the IDE Preferences, and installed the "Arduino SAMD Boards (32-bits ARM Cortex-M0+)" & "TinyCircuits SAMD Boards" choices using the Boards Manager as indicated in the instructions, then the "TinyScreen+" should be available for you to select under Tools->Board in the IDE.

You should also try simply reseating the microSD card several times in case minor corrosion has formed on the interface between the microSD card & the socket.

Hope that helps . . .


lennevia

  • Administrator
  • Hero Member
  • *****
    • Posts: 112
    • View Profile
Hello,

I hope this other informative comment from mjculross has helped you with the "No SD Card Found error" but if not, let me know if you are still encountering problems and we will try to resolve it! It may indeed be the SD Card having issues after so many years. For future reference, the TinyCircuits email for help is info@tinycircuits.com. Please let us know where you found an incorrect/dead email so we can make sure that doesn't happen to anyone else!

Thanks,

Réna



spetznatz1@gmail.com

  • Newbie
  • *
    • Posts: 2
    • View Profile
The only issue that I am having is that the URL that has to be added to Arduino IDE is incorrect. When I tried to include it in the version I have, (which I updated prior to doing this AND rebooted it), it tells me there is an error. I need to know what the correct URL is in order to add the "TinyCircuits" board in my Arduino software.
Please note, that I am VERY new to Arduino and I have completed a few projects with it, but I am still a beginner in my estimation.


lennevia

  • Administrator
  • Hero Member
  • *****
    • Posts: 112
    • View Profile
Hello,

If you have an error, it would be helpful to show us what it is so we can better help you.

The likely reason for the error as you try to add the Additional Boards Manager URL, found in the TinyScreen+ tutorial(https://learn.tinycircuits.com/Processors/TinyScreen+_Setup_Tutorial/#step-1-configure-arduino-software-ide): http://files.tinycircuits.com/ArduinoBoards/package_tinycircuits_index.json

is that you are missing a comma either before or after as you add it to the list. There is a picture in the tutorial with the link, and this may be helpful in placing the comma or being able to see if there are any large differences in this menu as you attempt to add the board URL.

I hope that helps, and let me know if it does not or if you have any more information on the error you are seeing!

Also, would still love to know where you found a dead email so that it can be corrected.

Thanks,

Réna


 

SMF spam blocked by CleanTalk