TinyCircuits

TinyZero, bootloader button and Arduino IDE

TinyZero, bootloader button and Arduino IDE
« on: November 20, 2019, 09:30:10 AM »
In case other people are having a similar issue: I was getting pretty annoyed at the serial port disappearing from the port selection menu and having to use the boot loader button on the TinyZero and thinking about giving up on it and going back to the TinyDuino. However, it now seems that it's (often at least, or all the time?) a simple matter of clicking out of the IDE and then clicking back into it. The serial port magically reappears. Maybe it's an IDE issue on the Mac (and PC?) and not the TinyZero issue I (we?) thought.
I've had a somewhat similar issue with a CAD program where selection tools start misbehaving and simply clicking to another tab window and back fixes it, so now I think to try this in other places, and it worked here. Pretty easy workaround. Two clicks, problem solved. Probably. I'd be interested to hear if someone's seen similar behavior.

Re: TinyZero, bootloader button and Arduino IDE
« Reply #1 on: November 22, 2019, 12:35:02 PM »
Update a couple days later with more experience with this. I haven't had to use the bootloader button in days. Seems clicking outside of the IDE and then getting back in (and a couple of times I cycled the power on the TinyZero while experimenting with this) will get the serial port to show up again.
Seems like more of an IDE issue than a TinyZero issue, although it works reliably on the TinyDuino. Hmmmm....