TinyCircuits

Problem with initial use of Bluetooth Low Energy TinyShield

Problem with initial use of Bluetooth Low Energy TinyShield
« on: October 20, 2013, 09:32:19 PM »
Hi all,

I'm attempting my first use of the Bluetooth Low Energy TinyShield but having some problems.  I downloaded the code provided on the tiny-circuits.com "Learn" page for the Bluetooth Low Energy TinyShield and installed the Arduino code library.  I uploaded the BGLib_stub_slave sketch to my TinyDuino successfully.  But execution seems to be stuck in Standby Mode (in order for the device to be detected it must be in Advertise Mode).  Is the code I downloaded meant to be plug-n-play?  If so, what am I doing wrong? If not, what should I do to get it functioning?

Thanks for your help! Let me know if I can provide any more specific information to help diagnose the problem.

Caroline

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #1 on: November 01, 2013, 10:32:03 AM »
I still haven't been able to get it to work. 

Could someone with the BLE try running the code from here?: http://tiny-circuits.com/learn/using-the-bluetooth-low-energy-tinyshield/

If it works for you and not for me, I'll be more convinced that there is something wrong with my BLE.

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #2 on: November 05, 2013, 10:07:14 PM »
Hi Caroline,

I greatly apologize for the delay in getting back to you on this.  Are you running the board with the USB board plugged in - if so this may be the cause of the issue since the Rev 1 BLE boards share the same UART as the USB Boards and cannot be used at the same time.

Best Regards,

Ken Burns
TinyCircuits

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #3 on: November 26, 2013, 02:26:19 AM »
Hi Ken,

So what is the solution to this? I bought the BLE shield last week and am unable to get it to work. Also the instructions on the "Learn" page are not very clear. Also, couple other questions

1. How do I get the BGLib libraries.
2. The sketch seems to require some include files which are not clearly mentioned in the code on the "Learn" page. As a result I am running into the following errors
  TinyDuinoBLE.ino:32:10: error: #include expects "FILENAME" or <FILENAME>
  TinyDuinoBLE.ino:33:19: error: BGLib.h: No such file or directory

Please help to fix this.

Thanks,
Abhinav

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #4 on: December 15, 2013, 05:14:42 AM »
I'm having a similar problem. I can't get the example BLE code to do anything. I can run the code but I can't discover the device using an iOS app like LightBlue, BLE Utility, or BLE Diag Tool. I've tried everything I could think of - including making sure only the BLE shield is connected to the processor board (disconnecting the USB & ICP shield) and running off of a coin battery but still nothing.

My BLE shield says ASD2112 - Rev2. Is there an updated version of the example code?

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #5 on: December 15, 2013, 03:27:31 PM »
Sorry for the lag in the docs, we've updated the Learn Page http://tiny-circuits.com/learn/using-the-bluetooth-low-energy-tinyshield/ with the changes needed for the Rev 2 board, please let me know if you continue to have problems after running this version. 

Thanks,

Ken
TinyCircuits

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #6 on: December 16, 2013, 01:59:41 AM »
Yay! Works now with the new example. Thanks

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #7 on: December 30, 2013, 06:07:43 PM »
Could anybody get it to communicate with another device? LightBlue for example?

I am trying to read from and write to the BLE module... but seems like event callbacks are not working. Appreciate any help with this. Thanks!

Yay! Works now with the new example. Thanks

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #8 on: December 30, 2013, 06:43:27 PM »
Can we just read directly from "SoftwareSerial" ? I am using a Rev 1 board.

Thanks!

RLH

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #9 on: February 22, 2014, 04:49:16 PM »
I just got the tinyduino starter kit. I also got the rev 2 Bluetooth LE.   I downloaded the code from the tutorial that is supposed to make it discoverable into the processor using the usb shield .  I remove the usb shield and am using just the processor board and the Bluetooth LE.  I have a fresh CR1632 in the coinholder.   The problem is, my PC (which is running windows 8.1) is not seeing the device.  My iPhone is not seeing the device either.  I also have an Arduino uno with another Bluetooth board ( not LE) and it is being seen by my PC.  I've been beating my brains out on this , please  Help!

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #10 on: February 22, 2014, 04:56:22 PM »
Hi RLH,

Well, you can't use BLE the same way you use classic bluetooth. That means BLE devices will not show up under available devices in settings.

Try with an app like LightBlue or BLE Utility on your iPhone. Also, you need to make sure that you have a device that supports BLE... such as iPhone 4S or up, iPad mini etc.

I just got the tinyduino starter kit. I also got the rev 2 Bluetooth LE.   I downloaded the code from the tutorial that is supposed to make it discoverable into the processor using the usb shield .  I remove the usb shield and am using just the processor board and the Bluetooth LE.  I have a fresh CR1632 in the coinholder.   The problem is, my PC (which is running windows 8.1) is not seeing the device.  My iPhone is not seeing the device either.  I also have an Arduino uno with another Bluetooth board ( not LE) and it is being seen by my PC.  I've been beating my brains out on this , please  Help!

RLH

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #11 on: February 22, 2014, 05:06:48 PM »
Thank you so much!  I just downloaded the BLExplorer app on my iPhone and it is seeing the tinyduino.  Now if there is a way to connect to my PC, that is my real goal.  Thanks

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #12 on: February 22, 2014, 05:10:02 PM »
Great!

If your pc isn't BLE compatible you might have to try with a BLE dongle. And also need to find a software (for BLE) that runs on windows.

RLH

Re: Problem with initial use of Bluetooth Low Energy TinyShield
« Reply #13 on: August 20, 2014, 11:45:52 AM »
Got the BLE Dongle.  Windows 8.1 Bluetooth settings sees the  My Arduino 7F:6F:8B!  Yay!  I can click on the Pair button and when I do the Tiny circuits device starts double flashing , indicating a "connection".  Eventually, Window's Bluetooth Settings widow comes back and says "That didn't work, check to see if device is still discoverable".  At the same time the Tiny circuits device goes back to blinking once.  How can I get the device to Pair with windows 8.1?  Thanks.