Problem with initial use of TinyDuino

Problem with initial use of TinyDuino
« on: September 06, 2013, 09:37:53 PM »

I am trying to get started with my TinyDuino processor board and USB shield.  I am following the directions on the "Getting Started with your TinyDuino" card that came with my package.  I installed the Windows VCP driver from here (http://www.ftdichip.com/Drivers/VCP.htm), and I installed the Arduino IDE (1.0.5).  I connect my shields together, attach the USB cable, connect it to the computer.  Windows finds the USB device.  I compile and upload the "Blink" example.

I get a message of:
avrdude: stk500_getsync(): not in sync: resp=0x30

and nothing happens.  I unplug and replug the usb cable, the 2 leds on the USB shield go bright for a second or two, and then the led on the processor board starts to blink.  It blinks about 5 times and then stops.

If I try to upload again, I have to unplug/replug the usb cable, and I get the same behavior.  This does not seem right.

What have I done wrong? How can I debug it to fix it?


Re: Problem with initial use of TinyDuino
« Reply #1 on: September 06, 2013, 09:44:15 PM »
I will also add that I did select the "Arduino Pro or Pro Mini (3.3v, 8Mhz) w/ ATMega328" for the board and COM3 for the serial port.


Re: Problem with initial use of TinyDuino
« Reply #2 on: September 20, 2013, 10:16:58 PM »
Did anyone have any advice on how to fix this?  Is there something wrong with my TinyDuino perhaps?


Re: Problem with initial use of TinyDuino
« Reply #3 on: September 23, 2013, 02:02:17 PM »
Hi Mark,

Sorry for the late reply - it definitely sounds like their is an issue with either the USB or the Processor board.  I've emailed you privately and we'll get this replaced immediately.



Re: Problem with initial use of TinyDuino
« Reply #4 on: October 02, 2013, 09:33:19 PM »
Thanks, Ken!

Just to follow up in the forum here, it appears to have been some kind of software installation problem.  When I tried the original boards on my home computer (I had tried on two different computers while traveling), everything worked as it is supposed to.  The blink program downloaded without errors and then ran correctly and continuously.  I don't know what was up with the environments on the other computers, but I am just happy that things are working as expected now.

So, thanks again for the great service!  Looking forward to using my boards on upcoming projects.


Re: Problem with initial use of TinyDuino
« Reply #5 on: November 04, 2013, 06:13:13 PM »
I just experienced something similar...
I spent a couple of hours, wondering if I had totally lost any understanding of how things works...
I read this post, installed the newest arduino (1.0.5) and voila... Everything worked.

It seemed like the first couple of commands in the loop would be executed, then everything would stop.
At some point it even seemed as though only the setup was actually run.

I don't know, if this means anything, but my 1.0.4 version of arduino was from Digispark.

Hope that helps somebody get to the root of similar problems! :)