TinyCircuits

[SOLVED] Black screen after Menu Update

[SOLVED] Black screen after Menu Update
« on: December 14, 2016, 01:55:41 PM »
Hello, I'm trying to update the menu following the doc, this happens :

Sketch uses 30,828 bytes (11%) of program storage space. Maximum is 262,144 bytes.
Atmel SMART device 0x10010005 found
Device       : ATSAMD21G18A
Chip ID      : 10010005
Version      : v1.1 [Arduino:XYZ] Sep  2 2016 16:29:24
Address      : 8192
Pages        : 3968
Page Size    : 64 bytes
Total Size   : 248KB
Planes       : 1
Lock Regions : 16
Locked       : none
Security     : false
Boot Flash   : true
BOD          : true
BOR          : true
Arduino      : FAST_CHIP_ERASE
Arduino      : FAST_MULTI_PAGE_WRITE
Arduino      : CAN_CHECKSUM_MEMORY_BUFFER
Erase flash
done in 0.829 seconds

Write 31096 bytes to flash (486 pages)

[===                           ] 13% (64/486 pages)
[=======                       ] 26% (128/486 pages)
[===========                   ] 39% (192/486 pages)
[===============               ] 52% (256/486 pages)
[===================           ] 65% (320/486 pages)
[=======================       ] 79% (384/486 pages)
[===========================   ] 92% (448/486 pages)
[==============================] 100% (486/486 pages)
done in 0.226 seconds

Verify 31096 bytes of flash with checksum.
Verify successful
done in 0.125 seconds
CPU reset.



And then nothing...

I'm able to enter the "bootloader mode" by pressing the 2 buttons, the upload seems fine, but the program doesn't seem to run... I just have a black screen.

Am I missing something ?

Thank you !
« Last Edit: December 17, 2016, 10:58:15 AM by ekryyn »

Re: Black screen after Menu Update
« Reply #1 on: December 17, 2016, 10:57:58 AM »
Ok solved... I've been using the wrong programmer apparently. I finally tried with AVRISP mkii and it worked.

Re: [SOLVED] Black screen after Menu Update
« Reply #2 on: January 01, 2017, 07:16:06 PM »
I got the problem with the black screen after updating the example program. With the sample program running, I switched the arcade off and I could only get a black screen and no port connection to the Arduino IDE. Thank to this thread I found out the existence of the bootloader mode by pressing the two buttons. That reestablished connection to the Arcuino IDE and could update the menu software thereafter. The existence of the bootloader mode should be mentioned in the update instructions for the menu software.