TinyCircuits

TinyArcade not working at all

TinyArcade not working at all
« on: October 02, 2016, 07:14:13 PM »
I just bought my tiny arcade yesterday, it was working fine, and last night I tried to update the tiny menu, where it had continuous compiling errors and resulted in my tiny arcade being stuck in bootloader mode. I tried again to load the tiny menu today, and after I did the screen went black. I tried unplugging and plugging the battery, turning the switch on and off, unplugging and plugging into my computer, the screen stays black and my computer does not recognize it at all. Would I be able to send it in to get returned/replaced?

Re: TinyArcade not working at all
« Reply #1 on: October 02, 2016, 08:27:08 PM »
I had a similar experience. I bought it at the NY MakerFaire 2016, assembled it, and it was working fine. I copied files onto an SD card and attempted to boot, but got the "Tiny Arcade Bootloader Mode" screen that I couldn't get past. I tried to install the Arcade Menu and after a lot of fighting with the Arduino IDE (e.g., the "cannot find sd.../...h" errors are from an older version of the Arduino IDE; upgrading fixed that problem but left me with the "cannot execute bossac" error for the Tiny+ menu example and countless "could not resolve symbol" errors in the Arcade Menu) finally managed to build a .bin file for the TinyScreenBasicExample and downloaded it by invoking the "bossac" executable (which actually was installed under my .arduino15/packages/arduino directory) directly. It claims it managed to flash the firmware, which I believe, because now it doesn't even appear as a USB device, let alone display anything on the screen.

In short, I bricked it. Help!  Any other way to flash the firmware?

Re: TinyArcade not working at all
« Reply #2 on: October 03, 2016, 06:37:59 PM »
First: these should not be bricked- try holding both push buttons and turning the power off then on again, you should see the bootloader screen- then you'll be able to upload new code. If they are bricked, we will definitely replace them, but it would be an issue we haven't seen before so we will try to resolve the problem first- let me know.

Further, sorry about the issues with compiling/uploading new code- I've updated our board support and menu code, so now the latest IDE, Arduino SAMD board package, and TinyCircuits board package should be working together properly. The menu update is available from https://tinycircuits.com/blogs/learn/171319495-tiny-arcade-menu-update

If you're not seeing anything on the screen, there's code that isn't starting up properly- be sure when you upload the menu to have the 'TinyArcade Menu' build option selected.

Stephen, just copying the files onto SD and turning it on seems to be a different initial problem from Mdbook- can you post further details in http://forum.tinycircuits.com/index.php?topic=1675.0 ?

We want to get these things figured out, thanks for your patience in posting the issues here.

Re: TinyArcade not working at all
« Reply #3 on: October 04, 2016, 09:01:51 AM »
I'm also having no luck- managed to update the menu, but then when I tried to load on the BasicExample, the screen went black & now it is totally unresponsive.

It isn't detected as a port (so I can't select the correct port in Arduino). I've tried holding down the buttons when switching on- but that doesn't do anything.

Do I have to take the whole thing apart to be able to access a reset button? Not sure I want to do this unless a last resort, as it's all nicely glued together...

Re: TinyArcade not working at all
« Reply #4 on: October 04, 2016, 09:12:24 AM »
Thanks much for the help, Ben. Things are working again.

Holding down the two buttons on power-on did make the bootloader screen reappear, so you were right: it wasn't bricked.

On Linux 14.04, I'm running Arduino 1.6.12 with the Arduino SAMD boards 1.6.7, newly updated TinyCircuits SAMD 1.0.5, and 1.1.0 of the TinyScreen library.

This time, I was able to compile the revised version of ArcadeMenu. When I power it on and hold the two buttons, the "TinyArcade Bootloader Mode" screen appears and the TinyScreen+ (/dev/ttyACM0 for me) port appears. I'm able to flash the firmware.

The games that were originally there don't seem to be there anymore, but now the SD card works as advertised (i.e., I unzipped the collection, wrote them on a newly formatted SD card, and now I'm able to select and play a game.

Re: TinyArcade not working at all
« Reply #5 on: October 04, 2016, 05:50:13 PM »
Hi again Jon, do you have the older version with a TinyScreen+ board or the new version with the case held together by a standoff/screws?

Stephen, glad it's working again, sorry about the original issue- will respond to that in the other thread.