TinyCircuits

ArcadeMenu troubles

ArcadeMenu troubles
« on: August 20, 2016, 04:55:43 PM »
I have uploaded a few test sketches on my tiny arcade through the arduino IDE, which worked. Afterwards I tried uploading the Arcade Menu sketch with the TinyArcade Menu option enabled. However, after the successful upload, the tiny arcade stays black. It even won't show up in the port options of the IDE.

I can get the port selection back on by holding the bottom right screen button when switching the screen on - then I can upload another sketch again with default compile options, which results in a working game.

However, I fail restoring the MenuArcade sketch - unless I compile it in default mode... then it seems to be working.

My sd card is seemingly not recognized by the menu - it's a 16gb sd card btw, formatted with fat32.

Re: ArcadeMenu troubles
« Reply #1 on: August 25, 2016, 05:25:47 PM »
I think I've figured it out:

- The Arcade Menu compile option is to be used when you export binaries that can be loaded from SD
- The Arcade Menu project itself is to be deployed normally (default)
- The SD card expects a folder that contains a .bin file with the same name (e.g.: "sample/sample.bin") and optionally a .tsv file with the same name

Re: ArcadeMenu troubles
« Reply #2 on: September 04, 2016, 03:31:03 PM »
Hi there, it's been a while. Sorry we are so far behind on proper documentation. I think we are finally ready to catch up since Kickstarter hardware has been shipped.

Do you have the latest software through the Boards Manager? There is a 'Binary for SD card' build option for exporting binaries which I do not see mentioned, so that may be causing problems.

Thanks,
Ben

Re: ArcadeMenu troubles
« Reply #3 on: September 05, 2016, 03:20:43 AM »
Hm. I've updated everything I think - but I have no such "Binary for sd card" option. Do I have to update my Arduino IDE version? I might be a couple of months behind.