Won't recognize microsd card

audiodude

  • Newbie
  • *
    • Posts: 2
    • View Profile
I just got and assembled my kickstarted TinyArcade and it's awesome!

But it won't recognize the microSD card. I've tried jamming it in there every way and I've settled on what I'm SURE is the right way.

What's going on? I've got sound and the joystick works.

Thanks,
-Travis


toomuchsoy

  • Jr. Member
  • **
    • Posts: 9
    • View Profile
I'm having the same exact problem. And my name is also Travis, so imagine how surprised I was to find that I traveled through time.

Also, I checked the card and all of the files are there, but it still only recognizes the three games you can play when there's no card at all.

-Another Travis


WookieeFart

  • Newbie
  • *
    • Posts: 3
    • View Profile
This is clearly a Travis interface issue.

- not Travis


toomuchsoy

  • Jr. Member
  • **
    • Posts: 9
    • View Profile
Not the first time that's been an issue. But barring a name change, I'd suuuure like to play some Tiny Asteroids.


Ben Rose

  • Administrator
  • Hero Member
  • *****
    • Posts: 342
    • View Profile
Hi Travis and Travis, really sorry about this- we've had a handful of reports of this and think we have a software fix, I'll update as soon as we know for sure.

Thanks,
Ben



Nickhen

  • Newbie
  • *
    • Posts: 1
    • View Profile
Just got my tiny arcade assembled and I'm also having the same problem. Otherwise it works great.


toomuchsoy

  • Jr. Member
  • **
    • Posts: 9
    • View Profile
Just got my tiny arcade assembled and I'm also having the same problem. Otherwise it works great.

Travis, I presume?


az

  • Newbie
  • *
    • Posts: 2
    • View Profile
I'll be an honorary Travis, just built my tinyarcade and have the same issue.


Ben Rose

  • Administrator
  • Hero Member
  • *****
    • Posts: 342
    • View Profile
Travis and others, we have a solution posted at https://tinycircuits.com/blogs/learn/171319495-tiny-arcade-menu-update

It does require using the Arduino IDE- let me know how this goes for you guys.

Thanks,
Ben


az

  • Newbie
  • *
    • Posts: 2
    • View Profile
Travis and others, we have a solution posted at https://tinycircuits.com/blogs/learn/171319495-tiny-arcade-menu-update

It does require using the Arduino IDE- let me know how this goes for you guys.

The fix worked for me!  Thanks so much.

-No Longer Travis


toomuchsoy

  • Jr. Member
  • **
    • Posts: 9
    • View Profile
Well... it was all going well, but then the menu wouldn't actually upload. So I went back and did all of the steps again and uploded that sample graphics program...

And now that program won't go away. No sample games anymore, and when I get to STEP THREE...

Board is TinyScreen+
Build Option is TinyArcade Menu
Port is... there's no option for TinyScreen+

So now I'm looking at cycling graphics. Gonna try to see if I can start over at all, but any help is appreciated.


toomuchsoy

  • Jr. Member
  • **
    • Posts: 9
    • View Profile
Yeah, still nothing. Now I'm just stuck on this graphics demo thing. Can't figure out how to reset this thing.

-Still Travis


Ben Rose

  • Administrator
  • Hero Member
  • *****
    • Posts: 342
    • View Profile
I'm not sure what caused the menu to not upload originally. But now it sounds like the example program was uploaded with the 'Tiny Arcade Menu' build option :) That combination would result in no USB conection. There's a small troubleshooting section at the end of the TS+ setup page, but this something that we clearly need to improve- it describes how to 'reset' the TS+ board. The way to do this is by holding down the button nearest the USB connector(on the actual TS+ board) and turning TS+ on to get the upload port back. This will require a paperclip or something similar to poke into the side of the Tiny Arcade to press the button. Let me know if you need a better description- I might not be able to get a picture up for a few days.


toomuchsoy

  • Jr. Member
  • **
    • Posts: 9
    • View Profile
Aha! I did it! Thanks for the walkthrough. I took it halfway apart to figure out where the button was... then realized that I could've gotten to it through a convenient hole. I'm back in action with the whole array of games.

Thanks, Ben! This is great.


 

SMF spam blocked by CleanTalk