TinyCircuits

Tinyshield BLE - control LED doesn't blink

Tinyshield BLE - control LED doesn't blink
« on: May 30, 2015, 02:46:00 AM »
Hallo together,

I'm trying to use the BLE rev2 board and I was already able to find it through some Android BLE App but now its not working anymore. From time to time i was able to make it visible and with the same programm and no changed settings its not visible anymore. I also recognized that sometimes (and than its available) the small amber colored LED on the BLE Board is on, but now most time its off.
What does this LED say? i wasn't able to find anything about it in the code. Should it glow permanent? Is it possible that the board itself is not working properly?

Thanks for your help!

Re: Tinyshield BLE - control LED doesn't blink
« Reply #1 on: June 18, 2015, 07:17:45 PM »
Hi Thea,

Missed your last post- cool project. I haven't worked with the Bluegiga BLE module in while, so I'll run some tests soon and make sure the libraries and tutorials are still working properly.

Re: Tinyshield BLE - control LED doesn't blink
« Reply #2 on: June 19, 2015, 01:24:35 PM »
Hey,
Thank you. This would be really helpfull.
I already had contact with the german reseller, and they tested the board and also didnt get it to work. now they orderd me a new one, which i test in the moment. But the same problems still appear.
I dont get it to work. My Adroid-Phone doesnt recognize it at all. (with same test-script (downloaded form your tutorial page) it was already working for some time).

Should this LED on the BLE Board be on?
I tried it with battery power (coin cell 3V) and with USB-Power. Both isn't working.

Your help would be really appreciated!
Thank you

Re: Tinyshield BLE - control LED doesn't blink
« Reply #3 on: June 23, 2015, 02:58:44 AM »
I found out, why the modul was not detected by my Phone.
When i downloaded the example BGLib_stub_slave I installed the libraries in my Arduino IDE. But without opening the libraries localy it brought up errors while compiling.
After some tries i found out that the BLE can be detected if only the local libraries (all 3: BGLib.cpp, BGLib.h, BGLibConfig.h) are in the projectfoldersand the installed ones are deleted (in C:\Program Files (x86)\Arduino\libraries).
I don't know if this is probably normal, but that was my mistake.

« Last Edit: June 23, 2015, 05:59:42 AM by Thea »