TinyCircuits

TinyShield Accelerometer not initializing?

TinyShield Accelerometer not initializing?
« on: March 28, 2016, 05:39:03 PM »
Hi,

I just purchased a TinyDuino basic kit and accelerometer board, and have a couple of issues:

1. it appears the accelerometer board I received isn't the one on the tinycircuits web site, rather the 9-axis IMU board instead (the board says, 'ASD2511 - Rev 4'.)

2. when I try to get the code bender project to run (https://codebender.cc/sketch:252367#TinyShield_9_Axis_Sensorboard.ino), it appears that initialization is failing. I placed some println(result, DEC)s after the WHO_AM_I I2Cdev::readByte() calls, and the result comes back as 0 from both. This is what appears to be causing initialization to fail (because IMUInit() is returning -1 shortly after)

Any ideas on what I can do to get the sample up and running?

Thanks for your help,

--Nitin

Re: TinyShield Accelerometer not initializing?
« Reply #1 on: March 29, 2016, 11:27:57 AM »
More information: I #defined I2CDEV_SERIAL_DEBUG to 1 in I2CDev.cpp and see the following in the serial monitor:

ArduinoIMU starting using device LSM9DS1
I2C (0x6A) reading 1 bytes from 0xF.... Done (0 read).
I2C (0x6B) reading 1 bytes from 0xF.... Done (0 read).
Failed to init IMU: -1
No valid compass calibration data
I2C (0x0) reading 1 bytes from 0x17.... Done (0 read).
I2C (0x0) reading 1 bytes from 0x17.... Done (0 read).
I2C (0x0) reading 1 bytes from 0x17.... Done (0 read).
...

That last line loops forever. So it appears that no i2c I/O is working, everything returns 0 as a result.

Does this give any additional clues?

Thanks,

--Nitin

Re: TinyShield Accelerometer not initializing?
« Reply #2 on: March 29, 2016, 01:08:24 PM »
ASD2511 is our 'Sensor Board' with a few optionally populated sensors. Our accelerometer board has switched from the specific board(2611) to this new board that works the same. You should use the accelerometer example code at https://codebender.cc/sketch:82279

I thought this was noted on our current product page- sorry about wasting your time, I'll ask for that to be fixed.