TinyCircuits Forum

General Category => General Discussion => Topic started by: DimSim1010 on June 15, 2018, 09:06:23 PM

Title: TinyDuino GPS Tracker not working
Post by: DimSim1010 on June 15, 2018, 09:06:23 PM
Hello people, I am a student trying out one of your projects at
It seems to not work and produces the following error:

Arduino: 1.6.8 (Mac OS X), Board: "Arduino Pro or Pro Mini, ATmega328 (3.3V, 8 MHz)"

failed MSpanList_Insert 0x30d000 0x1d44687b9f37 0x0
fatal error: MSpanList_Insert

runtime stack:
   /usr/local/go/src/runtime/panic.go:491 +0xad fp=0x7ffeefbff4a0 sp=0x7ffeefbff470
runtime.MSpanList_Insert(0x2ca028, 0x30d000)
   /usr/local/go/src/runtime/mheap.c:692 +0x8f fp=0x7ffeefbff4c8 sp=0x7ffeefbff4a0
MHeap_FreeSpanLocked(0x2c6c20, 0x30d000, 0x100)
   /usr/local/go/src/runtime/mheap.c:583 +0x163 fp=0x7ffeefbff508 sp=0x7ffeefbff4c8
MHeap_Grow(0x2c6c20, 0x8, 0x0)
   /usr/local/go/src/runtime/mheap.c:420 +0x1a8 fp=0x7ffeefbff548 sp=0x7ffeefbff508
MHeap_AllocSpanLocked(0x2c6c20, 0x1, 0x0)
   /usr/local/go/src/runtime/mheap.c:298 +0x365 fp=0x7ffeefbff588 sp=0x7ffeefbff548
mheap_alloc(0x2c6c20, 0x1, 0x12, 0x0)
   /usr/local/go/src/runtime/mheap.c:190 +0x121 fp=0x7ffeefbff5b0 sp=0x7ffeefbff588
runtime.MHeap_Alloc(0x2c6c20, 0x1, 0x10000000012, 0x10359)
   /usr/local/go/src/runtime/mheap.c:240 +0x66 fp=0x7ffeefbff5e8 sp=0x7ffeefbff5b0
MCentral_Grow(0x2ce998, 0x0)
   /usr/local/go/src/runtime/mcentral.c:197 +0x8b fp=0x7ffeefbff650 sp=0x7ffeefbff5e8
runtime.MCentral_CacheSpan(0x2ce998, 0x0)
   /usr/local/go/src/runtime/mcentral.c:85 +0x167 fp=0x7ffeefbff688 sp=0x7ffeefbff650
runtime.MCache_Refill(0x309000, 0x12, 0x0)
   /usr/local/go/src/runtime/mcache.c:90 +0xa0 fp=0x7ffeefbff6b0 sp=0x7ffeefbff688
   /usr/local/go/src/runtime/malloc.c:368 +0x57 fp=0x7ffeefbff6d0 sp=0x7ffeefbff6b0
   /usr/local/go/src/runtime/asm_amd64.s:273 +0x9a fp=0x7ffeefbff6d8 sp=0x7ffeefbff6d0
runtime.mallocgc(0x120, 0x1bf260, 0x0, 0x0)
   /usr/local/go/src/runtime/malloc.go:178 +0x849 fp=0x7ffeefbff788 sp=0x7ffeefbff6d8
runtime.newobject(0x1bf260, 0x309000)
   /usr/local/go/src/runtime/malloc.go:353 +0x49 fp=0x7ffeefbff7b0 sp=0x7ffeefbff788
   /usr/local/go/src/runtime/proc.go:233 +0x2a fp=0x7ffeefbff7c8 sp=0x7ffeefbff7b0
   /usr/local/go/src/runtime/proc.c:925 +0x1f fp=0x7ffeefbff7d8 sp=0x7ffeefbff7c8
runtime.malg(0x8000, 0x2b9680)
   /usr/local/go/src/runtime/proc.c:2106 +0x1f fp=0x7ffeefbff808 sp=0x7ffeefbff7d8
   /usr/local/go/src/runtime/os_darwin.c:137 +0x27 fp=0x7ffeefbff820 sp=0x7ffeefbff808
   /usr/local/go/src/runtime/proc.c:201 +0xc9 fp=0x7ffeefbff848 sp=0x7ffeefbff820
   /usr/local/go/src/runtime/proc.c:138 +0x55 fp=0x7ffeefbff870 sp=0x7ffeefbff848
runtime.rt0_go(0x7ffeefbff8a8, 0x14, 0x7ffeefbff8a8, 0x0, 0x0, 0x14, 0x7ffeefbffa50, 0x7ffeefbffa88, 0x7ffeefbffa94, 0x7ffeefbffaa4, ...)
   /usr/local/go/src/runtime/asm_amd64.s:95 +0x116 fp=0x7ffeefbff878 sp=0x7ffeefbff870
arduino-builder returned 2

Error compiling for board Arduino Pro or Pro Mini.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I tried to do the blink example sketch and that produces the same error. When I checked the Port, there was only two available and both don't work.
Title: Re: TinyDuino GPS Tracker not working
Post by: lennevia on June 18, 2018, 11:12:28 AM
Hey there!

It sounds like your Mac is having an issue recognizing your USB cable, did you check out the Port Trouble blog we have? Here it is: https://tinycircuits.com/blogs/learn/port-trouble-windows-and-mac-help so maybe you can find which port it is with some plugging and unplugging! 

This is a common issue among Mac users (myself included), so if that blog doesn't help, you may have to due some scanning for your USB connections. Here's a snippet from a post on the arduino forum:
"As already noted this is an OS problem. The port should appear (only when the Arduino is physically connected) as a pair of files /dev/tty.usbmodemXYZ and /dev/cu.usbmodemXYZ. The IDE gets its list of available ports from the OS.

There are utilities that may help your diagnosis, perhaps the standard Utility->Console will show some meaningful error message when you connect the Arduino. USB Prober is a dedicated tool available from the Mac developer site, and you may find downloadable copies around. I'm saying this because *apparently* some people solved their "device not recognized" problems just by running a low-level usb analyzer (???). I would also get rid of the FTDI drivers, just in case.

I run OSX 10.6.8 on a MBPro and have the same Vendor/Product/Version IDs, never had similar problems so far."
- https://forum.arduino.cc/index.php?topic=150734.0

This post is a few years old but it might be worth reading through!
Title: Re: TinyDuino GPS Tracker not working
Post by: DimSim1010 on July 28, 2018, 08:58:07 PM
I have made the code run using a windows computer.
However, when I turned on the serial monitor and followed the steps, instead of giving me NMEA data, it just says "No available data."

Another issue is when I try to unplug it from the micro USB cable and try to make it work with the battery, it does not provide a light when I switch it on. I think it that it should.

Many thanks
Title: Re: TinyDuino GPS Tracker not working
Post by: lennevia on July 31, 2018, 01:04:58 PM
Hello DimSim,

Have you written to the GPS module before trying to read from it? If there is no data previously written to it, there should not be anything to read off of the module.

Otherwise, the "No available data" message you're getting could be due to some incorrect addressing in the program. I took a look at the SPIFlash library that is necessary for this tutorial, and it has been renamed to "SPIFlash Memory." There are a few other SPIFlash libraries, so first make sure you have the correct version by Prajwal Bhattaram.

The yellow light that you see on on the TinyDuino when it is plugged into USB is the charging light for the battery, so when the USB is removed from the hardware, there should be no light on besides the green LED flashing every ten seconds on P13 while the GPS is in write mode.

Please let me know if that helps!

Thank you,

Title: Re: TinyDuino GPS Tracker not working
Post by: DimSim1010 on July 31, 2018, 05:28:58 PM
I have downloaded the library from this site: https://forum.arduino.cc/index.php?topic=324009.0
I downloaded the SPIFlash-2.60 version. Please tell me if this is the wrong version to download for the project.
Title: Re: TinyDuino GPS Tracker not working
Post by: lennevia on August 01, 2018, 11:39:40 AM

I downloaded the most recent version of the library (3.2.1) and was able to work through the tutorial successfully. The tutorial also works with the older version used in the tutorial.

Did you make any changes to the program? Are you still encountering the "No available data" message after allowing the GPS to write values?

Best of luck,
Title: Re: TinyDuino GPS Tracker not working
Post by: DimSim1010 on August 03, 2018, 10:14:21 PM
It finally works after lots of effort.
Thanks for your help
Title: Re: TinyDuino GPS Tracker not working
Post by: lennevia on August 06, 2018, 12:06:17 PM
I'm glad everything's working now!